Error: Could Not Create The Java Virtual Machine (fix Error)

Discussion in 'Crazy Craft 3.0' started by kelvinsc, Sep 18, 2015.

  1. kelvinsc

    kelvinsc New Member

    Below are some of the workarounds that have worked for different users.

    Try Setting Virtual Memory
    • Windows XP Users
      Click Start -> Control panel -> System -> Advanced -> Performance(setting) -> Advanced -> Virtual memory(Change) -> Click System managed size ->
      Set and then restart your computer.
    • Windows Vista Users
      Click Start -> Settings -> Control Panel - > System -> Advanced System Settings -> Advanced -> Click Settings under Performance -> Performance Options – Advanced -> Virtual Memory – Click Change – Select System Managed Size and then Restart Computer.
    Set JRE parameter to Less than 3/4th of Actual Physical Memory in Your System
    • To check physical memory on your system:
      Click Start -> Control Panel -> System. This will tell you Physical memory (RAM) on your system.
    • Set JRE parameter
      Click Start -> Control Panel -> Java(This opens Java Control panel) -> Java -> View -> In the last field which says Java Runtime Parameters enter -Xmx512M (Note: replace 512 with 3/4th of your actual RAM)
    Uninstall All Versions of Java through the Control Panel
    • Windows XP Users
      Click Start -> Settings -> Control Panel -> Add/Remove Programs. Select Java and click Uninstall.
    • Windows Vista Users
      Click Start -> Settings -> Control Panel -> Programs and Features. Select Java and click Uninstall.
    • Download latest Java from Java.com
    Disable Add-ons in Internet Explorer
    1. Open Browser
    2. Click Tools -> Internet Options -> Programs -> Manage add-ons.
    3. Select add-on that you wish to disable and then click Disable (Settings)
      Note: disable add-ons like SSVHelper Class, Windows Live Sign-in add-on, old Java plug-ins, etc.
    or
    simply change the version of your java to 64 bits, what was decided in my case (windows 10,8,7 64 bits)
    link: https://java.com/en/download/manual.jsp
    windows offline :)
     
    Pampeniica and SummerRitchez like this.
  2. McEvilJohn

    McEvilJohn VoidsWrath Modpack Overseer Staff Member

    I hope this is your own work x.x . Such a wonderful guide, shame if it was plagiarized.
     
  3. jackeo1

    jackeo1 New Member

    this worked for me :D it loaded all the mods and the other launcher so i had the choice for offical multiplayer one single play multiplay and mods.
    the offcial multiplay wouldnt load so i tried the singleplayer and it just crashes and doesnt respond
     
  4. Jhengis

    Jhengis New Member

    Console created...
    Java Command: javaw.exe
    com.voidswrath.voidlauncher.VoidLauncher.updateSteve(VoidLauncher.java:865)
    at com.voidswrath.voidlauncher.Downloader$2.run(Downloader.java:223)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    Exception in thread "main" java.lang.NoClassDefFoundError: joptsimple/OptionSpec
    at java.lang.Class.getDeclaredMethods0(Native Method)
    CrazyCraft2 v2.2 Minecraftv1.6.4 has stopped abruptly.(1)
     
  5. Pampeniica

    Pampeniica New Member

    This helped me a lot! I can finally play! :D Thank you!
     
  6. Roxybajainfan

    Roxybajainfan New Member

    Thank u so much this was my Problem :D
     

Share This Page